`
810364804
  • 浏览: 782770 次
文章分类
社区版块
存档分类
最新评论

fzu 2034 Password table (水)

 
阅读更多

Problem Description

Do you know password table? A password table is used to protect the security of the online account. When a user needs to login to his/her online account or pay for money, he/she may need to fill in the password according to his/her own password table. For example, if one user has the following table and the online system requires him/her to input the password of “A4B7D1”, he/she may input “577000”.

Input

The first line of the input contains an integer T(T≤100), indicating the number of test cases. The first line of each case contains three numbers n(5≤n≤9), m(5≤m≤9) and q(1≤q≤100) representing the length and width of the password table, and the total number of queries (Look at the password table above, its length is 8 and its width is 5). Each of the following n lines contains m numbers, representing the given password table.

Then, each of the following q lines represents a query with the format of "L1D1L2D2L3D3" (L1, L2 and L3 are letters. D1, D2 and D3 are digits), just like the example in paragraph one.

Output

For each test case, print a line containing the test case number (beginning with 1). For each query in one test case, please output its corresponding password in one line.

Sample Input

18 5 294 62 80 00 2479 11 07 80 0332 66 12 89 4857 82 36 69 3254 66 91 54 9312 14 37 92 8352 70 33 89 9559 91 01 80 69A4B7D1E5C3B2

Sample Output

Case 1:577000931211

Source

2011年全国大学生程序设计邀请赛(福州)

题意:略
思路:水。
代码;
#include <stdio.h>
#include <string.h>

int t, n, m, q;
char g[10][10][1005];

void init() {
    scanf("%d%d%d", &n, &m, &q);
    for (int i = 0; i < n; i ++)
	for (int j = 0; j < m; j ++)
	    scanf("%s", g[i][j]);
}

void solve() {
    char s[10]; int x, y;
    while (q--) {
	scanf("%s", s);
	for (int i = 0; i < 3; i ++) {
	    y = s[i * 2] - 'A'; x = s[i * 2 + 1] - '0' - 1;
	    printf("%s", g[x][y]);
	}
	printf("\n");
    }
}

int main() {
    int cas = 0;
    scanf("%d", &t);
    while (t--) {
	init();
	printf("Case %d:\n", ++cas);
	solve();
    }
    return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics